Back to overview
Degraded
TimePlan Cloud slow
Jun 20 at 10:06am CEST
Affected services
TimePlan Cloud
Resolved
Jun 21 at 08:14am CEST
A solution is now fully implemented
Affected services
Updated
Jun 20 at 02:51pm CEST
We have found a possible cause and are currently monitoring the effect of a solution
Affected services
Created
Jun 20 at 10:06am CEST
We are aware of the issue with TimePlan Cloud bad performance. We are looking into the issue.
Affected services